Top

What are the System Requirements for X8 software?

Operating Systems Supported

  • Mac OS X 10.7, 10.8, 10.9, 10.10, or 10.11

Minimum Hardware Requirements

  • Mac® computer with Intel® Core 2 Duo processor
  • 1.5 GB of available hard disk space
  • Internet connection required for NetUpdate security updates

Languages

  • English, French, German, Japanese, Spanish

 

Have more questions? Submit a request

Comments