Top

Personal Backup X8でファイルをバックアップする準備

Personal Backup X8のスクリプト管理

Personal Backup を使用する目的が、バックアップであろうと同期であろうと、起動ディスクのバックアップであろうと、いずれの場合でも、スクリプトを作成することで実行す る操作をプログラムに命令します。スクリプトは次の 2 つのパーツで構成されています:

  • コピーするソースファイルとそのコピー先の指定。
  • バックアップを実行する時間、バックアップ実行の前後に行う処理、重複ファイルの処理のしかた、などをコントロールするオプション。

Personal Backup の以前のバージョンで作成したスクリプトがない場合、はじめてプログラムを起動すると、バックアップ、起動ディスクバックアップ、同期というデフォルトの 3 つのスクリプトがウインドウに表示されます。これらスクリプトには、いずれもソース、コピー先、オプションは設定されていません。

これらデフォルトのスクリプトを利用してもいいですし、またそのスクリプトを削除して独自のスクリプトを作成することもできます。新たにスクリプトを作成するには、「ファイル」 > 「新規スクリプト」と選択するか、Command-N キーを押します。

 

あるいは、「+(プラス)」ボタンをクリックします。

Screen_Shot_2012-12-06_at_2.08.58_PM.png

 

「バックアップ」、「起動ディスクバックアップ」、「同期」の選択肢が表示されます。その中から作成するスクリプトの種類を選択します(各スクリプトの種類ついては、本ユーザーズガイドの「バックアップについて」のセクションを参照してください)。

 

 

ここでは例として「バックアップ」を選びます。すると「名称未設定バックアップスクリプト」という名前のスクリプトが追加されます。

 

もう一度同じ操作を繰り返すと、最初に作成したスクリプトの下に、次に作成したスクリプトが「名称未設定バックアップスクリプト 2」という名前で追加されます。

お 使いの Mac のスクリーン設定によっては、スクリプトの名前が表示しきれない場合があります。これは必要に応じて修正できます。まず、スクリプトのリストと設定エリア を分割している縦のライン上にカーソルを合わせるか、スクリプトリストのタイトル「スクリプト」という表示の隣にある三本の短い縦ラインにカーソルを移動 します。カーソルが左右に向いた小さな矢印のついた太い縦ラインに変化しますので、マウスが正しい操作位置にあることがわかります。カーソルがこの状態の ときに、スクリプト名がすべて表示される位置まで区切りのラインを右方向へドラックします。

 

 

次 に、例えば二番目に作成したスクリプトを削除するとします。スクリプトを削除するには、リストからスクリプトをクリックして選択し、「-(マイナス)」 ボタンをクリックします。または、Control キーを押しながらスクリプトをクリックし、表示されるメニューから「削除」を選択します(このような「コ ンテキストメニュー」が Personal Backup の随所で利用できます)。

 

 

いずれの場合も、その操作を実行してよいかどうかを確認するダイアログボックスが表示されます。

 

 

この時点で、「名称未設定バックアップスクリプト」と呼ばれるスクリプトは 1 つだけになります。スクリプトの名前を変更するには、左側のリストでスクリプト名をダブルクリックして、新しい名前を入力します。入力したら、tab、 enter、return キーのいずれかを押せば、新しい名前が反映されます。


 

同期や起動ディスクバックアップのスクリプトも、バックアップスクリプトとまったく同じ方法で設定できます。違いは、一目でスクリプトの種類が識別できるように、デフォルトのアイコンとしてそれぞれ異なるアイコンが設定されているだけです。

 

スクリプトを1つ作成したら、それにほんの少しの変更を加えて、似たようなスクリプトをもう1つ作成したい場合があります。このような場合、Control キーを押しながらコピーしたいスクリプトをクリックし、表示されるメニューから「複製」を選択します。

 

 

新たなスクリプトは、複製されたスクリプトの名前の後ろに「コピー」という語がついた名前で作成されます。このスクリプト名も、上述の手順で希望する名前に変更できます。

スクリプトのソースおよびコピー先の指定

こ れまでの操作で、スクリプトが1つ以上作成されました。次のステップは、どのファイルをコピーするか、そしてどこにそのコピーを作成するかを設定すること です。このプロセスは、バックアップ、起動ディスクバックアップ、そして同期でも似通っていますが、それぞれ確実な違いがありますので、1つ1つ個別に説 明します。

前述の通り、「ソース」とは、バックアップされるファイル、起動可能なバックアップ元となるファイル、または同期される対象のファイルの場所を指します。 「コピー 先」とはファイルのコピーの保存先です。

ソー スとコピー先の設定という点から言うと、最も自由度が高いのがバックアップです。複数のバックアップソースを指定することができます。例えば複数のフォル ダの中身、また複数のネットワークボリュームの中身でさえも、1 つのコピー先に複製できます。バックアップするソースは、Mac OS X を実行しているコンピュータ上にある必要はありません。実際のところ、オペレーティングシステムが実行されていなくても構いません。これは、コンピュータ のドライブに加え、外部ディスク、ネットワークボリューム、メモリスティック、iPod、またその他 Mac OS X が読み取り可能な媒体からバックアップできるということです。同様に、Mac OS X で書き込み可能なあらゆる媒体バックアップができます。

同期は、いずれのフォルダやボリュームから、いずれのフォルダやボリュームも可能です。ただし、バックアップとは違い、個別のファイルを同期したり、複数のソースから同期したりすることはできません。

注意:他 社のバックアップ ソフトでは、増分/差分バックアップを「同期」と呼んでいる場合がありますが、Personal Backup で増分/差分バックアップを行いたい場合は、必ずバックアップを使ってください。Personal Backup の同期は、双方向にファイルをコピーし、必要ならファイルを削除することもあります。思わずファイルが変更されたり、削除されたりすることを避けるために も、「同期」がどのような処理を行うか完全に理解し、必要と判断した場合以外、「同期」を使用しないでください。

起 動ディスクバックアップは、非常に特殊なタイプの処理です。ソースは Mac OS X がインストールされたディスクまたはボリューム全体でなければならず、そのコピーの作成先も起動可能な媒体でなければなりません(Personal Backup では、DVD に起動可能なバックアップを作成しません)。

注 意:はじめて起動 ディスクバックアップを実行したら、その「コピー先(クローン)」から Mac が起動し、正常に動作するかどうか、必ず確認してください。お使いのハード ディスクやその接続方式によっては、「クローン」から Mac が起動できないことがあります。あるいは、起動ディスクバックアップ中にエラーが起きるなどして、起動ディス クバックアップが完了していないこともあり得ます。「クローン」から Mac が正常に起動できない、あるいは正常に動作しない場合は、コピー先ハードディス クを初期化してから、再度起動ディスクバックアップをお試しください。どうしても「クローン」から Mac を起動できない場合は、該当するハードディスクが Mac OS X の起動ディスクに対応しているか、ご確認ください。

ソースとコピー作成先の指定

バックアップ、起動ディスクバックアップ、同期のいずれを作成するかに関係なく、Personal Backup ウインドウの上部セクションでソースおよび作成先を定義します。

 

ソースおよびコピー先を指定するには以下の5つの方法があります:

    • ドラッグ&ドロップ: 項目を Finder から Personal Backup ウインドウのソースおよびコピー先にドラッグ&ドロップします。




    • クリック: ウインドウのソースまたは作成先エリアをクリックして、ファイル選択ウインドウで項目を指定し、「選択」ボタンをクリックします。

 

 

    • メニューオプション: 「スクリプト」メニューから「ソースを選択…」または「コピー先を選択…」を選択します。




    • ショートカットキー: Option キー、Command キー、そして S キーを同時に押してソースを選択します。Option-Command-D キーを押してコピー先を選択します(上記のメニューコマンドと同じです)。
    • ポップアップメニュー: Personal Backup メインウインドウのソースおよびコピー先エリアにそれぞれ表示されるポップアップメニューから場所を選択します。このメニューは起動ディスクバックアップの作成時のみ表示されます。


 

ソー スやコピー先として、フォルダやボリュームが指定できるだけでなく、Personal Backup ではそのほかのオプションも用意されています。「ソース」エリアまたは「コピー先」エリアをクリックすると、項目を選択できるウインドウが開きます。デ フォルトでは、「種類」メニューで「ローカルのファイルまたはフォルダ」が選択されています。このメニューをクリックすると、利用できるそのほかのオプ ションが表示されます。利用できるソースは下図の通りです:

 

また、利用できるコピー先は下図の通りです:

 

ネットワークドライブ

ソースおよびコピー先としてネットワークドライブを使用できます。ネットワークドライブを選択するには、「種類」メニューから「ネットワークドライブ」を選択します。下図のようなネットワークドライブの情報を入力するダイアログが表示されます: 

 

ま ずアドレスを入力します。これには、マウントしたい Mac のシステム環境設定の「共有」画面に表示される iMac.local のようなローカルアドレス、 smb://servername のような Windows 共有、または ftp://example.comやsftp://example.com のよう にアドレスで識別される FTP や SFTP サーバ、さらに IP アドレスで識別されるリモートコンピュータ上のネットワークボリュームがあります。上記のケー スいずれの場合も、ボリュームやフォルダ名を含むフルアドレ スを入力する必要があります。Finder にマウンドできるすべての種類のネットワークボリュームが追加できます。実際、Finder でネットワークボ リュームをマウントし、そのアイコンを上図の「アドレス」フィールドにドラッグするのが、アドレスを指定する一番簡単な方法です。

「次の ユーザとして自動的に接続」チェックボックスをチェックし、名前とパスワードを入力すると、スクリプトの実行時にユーザ情報を入力するよう求められませ ん。また、「必要に応じてコンピュータのスリープを解除する」チェックボックスをチェックすれば、Personal Backup がネットワークボリュームが存在するコンピュータのスリープを解除しようと試みます(注意: すべてのコンピュータのスリープが解除できるわけではありません)。

「設定をテスト」ボタンをクリックすると、設定が正しいかどうかを確認できます。

Spotlight 検索

Mac OS X の検索機能である Spotlight の検索をスクリプトのソースとして利用できます。Spotlight 検索を利用するには、「種類」メニューから「Spotlight 検索」を選択します。Spotlight 検索を設定するシートが表示されます。

 

検索条件を設定するには、まずメニューの「検索場所」から場所を選択します。選択肢は、「コンピュータ」(お使いの Mac)、「ホームフォルダ」(現在ログインしているユーザのホームフォルダ)、または「その他」です。「その他」を選択すると、検索対象のフォルダまた はボリュームを任意に選択できます。

次に、検索の条件を設定します。例えば、最初のメニューで「更新日」を選択し、二番目のメニューで「次より後の項目」を選択して、テキストフィールドに日付を入力します。または、特定のタイプのファイルを指定することもできます。例えば、 「種類」 > 「次を含む項目」 > 「Word」と選択すれば、Microsoft Word 書類が検索できます。Spotlight 検索についての詳細は、Mac OS X ヘルプを参照してください。

Spotlight 検索条件を保存した形態であるスマートフォルダを Finder から Personal Backup ウインドウの「ソース」エリアにドラッグすれば、その検索条件をソースに追加することもできます。スマートフォルダが Finder のサイド バーに追加してある場合は、任意の Finder ウインドウでそのフォルダをクリックして開き、そのスマートフォルダのアイコン(ウインドウのタイトルバー に表示されるアイコン)を Personal Backup ウインドウの「ソース」エリアにドラッグします。

光ディスク

光ディスク(CD や DVD)をソースまたはコピー先として使用できます。光ディスクをソースとして使用するには、そのディスクをお使いのMacのドライブに挿入し、マウント されるのを待ちます。次に「ソースを選択」ダイアログでそのディスクを選択します。または、そのディスクをPersonal Backupウインドウの「ソース」エリアにドラッグします。ディスクをコピー先として使用するには、「コピー先を選択」ダイアログの「種類」メニューか ら「光ディス ク」を選択します。下図のようになります:

 

 

お使いの Mac に複数の光学式ドライブが存在する場合は、「使用するドライブ」メニューからドライブを選択します。Personal Backup でバックアップスクリプトを実行した後に、ディスクを検証するには、「バックアップ後にディスクを検証する」オプションをチェックしておきま す。検証にかかる時間は数分ですし、ディスクが正常に読み取れるかどうかを念のために確認するべきですから、検証は実行したほうが良いでしょう。このオプ ションのチェックを外すと、時間は節約できますが、ディスクが読み取れないのに気づかず、いざというときにバックアップが使えない可能性もあります。

光ディスクをコピー先として選択すると、ほかのコピー先を選択したのとは異なるバックアップオプションが表示されます。(オプションについて詳しくは、Personal Backup のスクリプトオプションのセクションを参照してください。)「バックアップ・オプション」の「モード」メニューには2つの選択肢があります:

 

変更したファイルのみコピーするか、すべてのファイルをコピーするかのいずれかのみ選択できます。バックアップを実行するたびにすべてをコピーする 場合、 各バックアップディスク(またはディスクのセット)にはすべてのファイルがコピーされます。何らかのファイルを復元する必要が生じた場合、いずれのバック アップディスク(またはディスクのセット)からでも復元できます。

変更したファイルのみをコピーするよう指定した場合、増分バックアップ を作成することができます。この場合、新たなディスクには前回のバックアップから変更されたファイルのみが書き込まれます。このため、Personal Backupで新しいディスクにコピーを開始する前に、前回のバックアップで作成した最後のディスクを挿入するよう求められます(例 えば、前回3枚の DVD に渡るバックアップを実行した場合、3枚目のディスクを Mac に挿入する必要があります)。これにより、Personal Backup がすでにバックアップされているファイルについての情報を読み、どのファイルをコピーする必要があるか判断できるようになります。

注意:Personal Backup では、マルチセッションのバックアップを CD に作成することは可能ですが、DVD には作成できません。これは Mac OS X の光ディスクへの書き込み用フレームワークが DVD へのマルチセッションの書き込みに対応していないためです。ですので CD 上の空きスペースを増分バッ クアップに使用することは可能です。CD にバックアップするとき、容量全体の半分しか使われなかった場合は、残りの空きスペースを次回のバックアップに使用できます。

ディスクイメージ

ディスクイメージをソースまたはコピー先にすることができます。ディスクイメージをソース として使用するには、Finder にマウントして「ソースを選択」ダイアログでそのディスクイメージを選択しするか、マウントしたディスクイメージ (.dmg ファイルではありません)を Personal Backup ウインドウの「ソース」エリアにドラッグします。ディスクイメージをコピー先として使用するには、「コピー先を選択」ダイアログの「種類」メ ニューから 「ディスクイメージ」を選択します。下図のようになります:

 

 

こ のダイアログで、ディスクイメージの名前を指定し、「変更」をクリックしてディスクイメージを保存する場所を指定します。または「場所…」フィールド上 にフォルダやボリュームをドラッグしても場所を指定できます。ディスクイメージを圧縮するには、「圧縮」ポップアップメニューから圧縮形式を選択します。 また、バックアップを暗号化するには、「暗号化」ポップアップメニューから暗号化を 2 つのレベルから選択します。

作成したスクリプト をはじめて実行するとき、Personal Backup によってディスクイメージが作成されます。それ以降は、そのとき作成された既存のディスクイメージが毎回 Personal Backup によってマウントされます。指定したディスクイメージが元の場所から移動されると、Personal Backup で指定されている場所に同じ名前のディスクイメージが新たに作成し直されます。ですので、指定した.dmgファイルは移動しないでください。

Personal Backup では、ディスクイメージのサイズの指定は求められません。Personal Backup が適切なサイズを自動的に決定します。バックアップを実行するたびに、Personal Backup が必要に応じてディスクイメージのサイズを増減します。ですので、ディスクイメージのサイズを心配する必要はありません。

ソースとコピー先の変更

ソー スやコピー先をいったん決定しても、それぞれのエリアをクリックして表示されるポップアップメニューから別のオプションを選び直せば、ソースやコピー先を 変更できます。選択できるオプションは、バックアップ、起動ディスクバックアップ、同期のいずれのスクリプトを編集するかによって異なります。

バックアップのソースにはほとんどどんな項目でも指定可能です。単一のファイルやフォルダ、ボリューム、またはディスク全体、さらに複数のデバイスにまたがるそれら項目の組み合わせのバックアップを実行するスクリプトを作成できます。

 

スクリプトの種類

オプション

バックアップのソース

鉛筆アイコンをクリックして新たに選択し直すことで、ソースを編集します。

「-(マイナス)」アイコンをクリックして、現在の選択を取り除きます。

「ソースを追加…」をクリックしてほかのソースを選択して、ソースを追加します。

バックアップの作成先

Mac OS X で書き込み可能な単一の場所(フォルダ、ボリューム、ドライブ)です。

バックアップのソースでのオプションと同じですが、「ソースを追加…」が「作成先を変更…」になります。これは鉛筆アイコンをクリックするのと同等です(バックアップの作成先は 1 つしか選択できません)。

同期のソース

Mac OS X で書き込み可能な媒体の単一の場所(フォルダ、ボリューム、ドライブ)です。

バックアップのソースでのオプションと同じですが、「ソースを追加…」が「ソースを変更…」になります。これは鉛筆アイコンをクリックするのと同等です(同期のソースは 1 つしか選択できません)。

同期の対象

Mac OS X で書き込み可能な媒体の単一の場所(フォルダ、ボリューム、ドライブ)です。

同期のソースでのオプションと同じですが、「ソースを変更…」が「作成先を変更…」になります。

起動ディスクバックアップのソース

Mac OS X を起動可能なボリュームがすべて表示されます。

起動ディスクバックアップの作成先

現 在マウントされているすべてのボリュームの中で Mac OS X がインストール可能なボリューム、および起動ディスクバックアップのソースの内容すべてを含む単一ファイルを作成するオプション「ASR ディスクイメージ」が表示されます。ASR ディスクイメージファイルは持ち運びに便利で、ソースディスクから複数のコピーを作成できるため、例えばネットワーク上のすべての Mac の内容を標準化する目的などに使用できます。

起動ディスクバックアップの作成先はソースと同じではあり得ません。作成先をソースと同じにしようとすると、Personal Backup は両者が重複しないよう、先に選択してあったほうの場所を別の場所に変更します。

スクリプトのロック、書き出し、および読み込み

これまで、バックアップスクリプトを共有したり保護する必要がない単独の Mac ユーザの観点から Personal Backup について説明してきました。けれども、コンピュータを共有する場合、ほかのユーザから作成したスクリプトを保護する必要も出てきます。また、知り合いに Personal Backup を所有しているユーザがいるなら、自分のスクリプトの内容を見てもらうためそのユーザと自分のスクリプトを共有したいと思うかもしれません。

Personal Backup には、スクリプトが偶発的に変更されるのを防ぐためのごく簡単なロック機能が搭載されています。スクリプトそれ自体は重要な情報ではないため、この「ロッ ク」はセキュリティ対策というよりは、むしろ抑止効果を期待するものです。例えば、スクリプトのロックを解除するのにパスワードは必要ありません。ですが スクリプトを誤って削除したり変更してしまうのを防ぐには十分な効果が望めます。

スクリプトをロックするには、以下のいずれかを実行します:

    • Control キーを押しながらスクリプト一覧でスクリプトをクリックし、表示されるコンテキストメニューから「設定をロック」を選択します。




    • 「スクリプト」 > 「設定をロック」メニューと選択します。


 

  • Command-L を押します。

スクリプトのロックを解除するには、コンテキストメニューから「設定のロックを解除」を選択するか、「スクリプト」 > 「設定のロックを解除」メニューと選択するか、もう一度 Command-L を押します。

ス クリプトを書き出すには、スクリプト一覧でスクリプトをクリックし、「ファイル」 > 「スクリプトを書き出し…」を選択するか、Command-Shift-S キーを押します。書き出されたスクリプトを読み込むには、書き出した Personal Backup が自分のプログラムかほかの人のものかに関わらず、「ファイル」 > 「スクリプトを読み込む…」を選択するか、Command-O キーを押すか、または Finder のスクリプトファイルのアイコンをダブルクリックします。

書き出されたスクリプトは、ソースやコピー先の場所の情報を含むすべてのオプションが記述された標準テキスト形式の XML ファイルです。同一の場所にソースやコピー先が存在しない Mac にそのスクリプトを移動した場合は、そのスクリプトは開けますが作動しません。

Personal Backup のスクリプトのオプション設定

ここまで、バックアップや起動ディスクバックアップ、同期を実行する Personal Backup スクリプトの作成方法、バックアップされるファイルの表示のしかた、作成したスクリプトの保護のしかた、さらに Personal Backup がインストールされた Mac 間でスクリプトをやり取りする方法について説明しました。作成したいずれのスクリプトも、左側のスクリプト一覧からそのスクリプトをクリックして、右下に ある「実行」ボタン(右向きの三角形)を押せば、いつでも実行できます。

ですが Personal Backup では、いままで紹介してきた操作よりも一層多彩な処理をスクリプトオプションを使って実現できます。

スクリプトを実行する時刻、スクリプトを実行する前後の処理、重複するファイルが見つかった場合の動作など、Personal Backup のカスタムオプションは、実質上すべてスクリプトオプションで設定します。スクリプトオプションは Personal Backup ウインドウの下部に 5 つのグループに分けて、次のように表示されます:

 

 

  • スケジュール: ス クリプトを定期的に実行できます。お使いの Mac がスリープ状態であればこれを解除したり、ログインしていない状態でもスクリプトを実行したりできます。スケジュールは複数のパーツで構成でき、例えば毎 週月曜日と水曜日の午後 5 時にバックアップを実行し、毎月 1 日に再度バックアップを実行するというような指示を Personal Backup に出すことができます。
  • 準備:スクリプトの実行前にほかのプログ ラムを実行す るよう Personal Backup を設定することができます。最も一般的に実行されるプログラムは VirusBarrierです。このプログラムは、マルウェアなどの危険なファイルを検出し、コピーによってほかのファイルやコンピュータに感染が拡大し てしまうのを未然に防ぎます。またカスタムの AppleScript など、他の任意のプログラムを実行するよう Personal Backup に指示することも可能です。このとき複数のプログラムを順次実行することができます。
  • 例外条件: Personal Backup では、条件を詳細に絞り込んで、どのファイルをコピーするかを自由に制御できます。ファイルの可視性、名前、種類、パス、サイズ、作成日、更新日、ラベ ル、あるいはこれらを組み合わせて、ファイルをバックアップする(あるいはしない)かどうかを指定できます。
  • オプション: バックアップ、起動ディスクバックアップ、同期の3種類のスクリプトに、それぞれ固有の選択肢があります。保管するバックアップの数、エイリアスとそのオ リジナルのファイルをコピーするか、ファイルがソー スのディスクあるいはコピー先のディスクの両方で変更されていた場合はどうするかなどです。
  • 仕上げ:「準備」オプションと同様に、スクリプトの実行後に、 仕上げとしてプログラム(または AppleScript)を実行するよう Personal Backup に指示します。コピー先ディスクのマウントを解除したり、プログラムを終了したり、他の Personal Backup スクリプトを続けて実行したり、Mac OS X をスリープ状態にしたり、さらにシステム終了したりすることができます。

こ れら5つのオプションのグループは、それぞれのオプションのボタンをクリック、メニューから選択、割り当てられたショートカットキーの押下という3つの操 作法で表示できます。各オプションのセットは、Personal Backup のメインウインドウにある「オプション」の部分に、それぞれのグループに分けて表示されます。これらのオプションは必ずしも指定する必要はありません。指 定しない場合、Personal Backup のデフォルトのオプション設定でスクリプトが実行されます。

メインウインドウの「オプション」部分に表示されるカスタムオプションを取り除き、デフォルトのオプションに戻すには、次の3通りの方法があります:

  • 「オプション」ウインドウのグループ右上にある小さな「x」ボタンをクリックします。

 

  • それぞれのオプションのグループを表示するのと同じショートカットキーの組み合わせを押します。
  • それぞれのオプションのグループを表示するのと同じメニュー項目を選択します。

いずれの場合も、その操作を実行してよいかどうかを確認するダイアログボックスが表示されます。

 

 

スケジュール

Personal Backupスクリプトは、メインウインドウの右下にある「実行」ボタン(右向きの三角形)を押せば、いつでも実行できます。ですがバックアップや同期で もっとも便利 な処理は、ユーザが操作する必要なく、つまりユーザが気に掛けることなく定期的に実行できることです。例えば、外付けのハードディスクを差し込むたびに自 動的にバックアップスクリプトを実行したり、あるいは2台のコンピュ ータが同じネットワーク上にあるときは常に同期化を行うなど、「スケジュール」オプションで便利な処理を自動的に実現することができます。

Personal Backup の「スケジュール」オプションを開くには、以下の操作のいずれかを行います:

  • 「スクリプト」 > 「オプション」 > 「スケジュール」と選択します。
  • Command-1 キーを押します。
  • Personal Backup メインウインドウの下部にある「スケジュール」ボタンをクリックします。

 

「スケジュール」オプションが表示されます。

 

「ス クリプトを実行」セクションで、選択したスクリプトを Personal Backup で定期的に実行させることができます。まず「スクリプトを実行」チェックボックスをチェックします。次にポップアップメニューから期間を選ん で、スクリプトを実行する頻度を設定します。頻度には以下のオプションがあります:

  • 毎日: 時刻を選択します。
  • 毎週: 曜日と時刻を選択します。
  • 毎月: 日付と時刻を選択します。
  • 毎___: 期間の長さと単位(分・時・日・週・月)を選択します。例えば、これで 20 分や 3 ヵ月ごとにスクリプトを実行させることがで きます。

「+ (プラス)」ボタンをクリックして「スクリプトを実行」セクションに行を追加することで、複雑な予約を設定することが可能です。例えば、下図では毎週月曜 日と金曜日の午後 11 時にスクリプトを実行し、さらに毎月 1 日の午前 1 時にも実行するよう設定しました。

 

 

条件を削除するには、条件の右側の「-(マイナス)」ボタンを押します。設定しているスクリプトのスケジュールをすべて(削除せずに)無効にするには、「スクリプトを実行」チェ ックボックスのチェックを外します。

このグループには、他にも以下のような 3 つのコントロールがあります:

  • 「必要に応じてコンピュータのスリープを解除する」を チェックすると、Mac が省電力状態の 「スリープ」モードに移行しても、Personal Backup が予約されたスクリプトを実行します。スクリプトが完了した時点でもコンピュータは通常モードのままになります。「仕上げ」オプションで、スクリプトが終 了したときにコンピュー タをスリープ状態にする設定をオンにすれば、スリープ状態に戻せます(この設定方法については、後述の「仕上げ:ファイルの後処理」を参照してください)。コンピュータが単にスリープ状態ではなく、完全に電源がオフの状態にある場合、このオプションでもコンピュータの電源が入るわけではないことに注意してください。
  • 「自分がログインしていないときでもスクリプトを実行する」をチェックすると、スクリプトの実行時に誰もログインしていない場合や、他の人がログインしている場合でも、スクリプトを実行させることができます。
  • 「ボリューム ____ の準備ができているときにスクリプトを実行する」を チェックすると、お使いの Mac から指定ボリュームが見えると、自動的にスクリプトが開始されます。これは、例えばネットワークに接続したとき、あるいは外付けハードディスクを起動ある いは接続した場合などです。Mac の起動ディスクを除き、 このスクリプトのソースあるいはコピー先として与えられたボリュームは、すべてポップアップメニューから利用できます。ソースとコピー先が両方とも Mac の起動ディスク上にある場合、このオプションは利用できません。

準備: ファイルの前処理

Personal Backup の「準備」オプションを開くには、以下の操作のいずれかを行います:

  • 「スクリプト」 > 「オプション」 > 「準備」メニューと選択します。
  • Command-2 キーを押します。
  • Personal Backup メインウインドウの下部にある「準備」ボタンをクリックします。

 

 

こ のオプションで、Personal Backup がコピーを作成する前に任意のプログラムを実行できます。バックアップや同期を行う前に Mac ユーザが最も実行したいのがウィルスのチェックであるため、Integoのアンチウイルスソフト、VirusBarrier専用のオプションを最初の チェックボックスとして用意しました。Intego VirusBarrier がインストールされていれば、Personal Backup が VirusBarrier でファイルをスキャンできます。

二番目のチェックボックスでは、スクリプトにまず任意のア プリケーションを実行させられます。前処理として実行するアプリケーションには、 GUI を搭載する Mac アプリケーショ ン、AppleScript、シェルスクリプト、Automator のワークフロー、あるいはスクリプトが始まるのを知らせるサウンドファイルなどが考えられます。このオプションをチェックにすると、実行するプログラムを 選択するためのダイアログボックスが表示されます。後でプログラムを変更するには「選択…」ボタンをクリックします。

 

例外条件

Personal Backup の「例外条件」オプションを開くには、以下の操作のいずれかを行います:

  • 「スクリプト」 > 「オプション」 > 「例外条件」と選択します。
  • Command-3 キーを押します。
  • Personal Backup のメインウインドウの下部にある「例外条件」ボタンをクリックします。

 

最初の2つのポップアップメニューでは、設定した条件の「いずれか」または「すべて」を満たす項目をコピーする(またはコピーしない)ように指定し ます。例 えば、 この選択肢を変更することで、名前に「cache」が含まれるファイルのみをコピーするかコピーから除外するか、あるいは他の条件を満たすファイルと一緒 にコピーするかなど、まったく異なる処理を指定できます。

次のセクションでは、フィルタに検出してほしい情報の種類を指定します。条件 は、 可視性、名前、種類、パス、サイズ、作成日(ファイルを実際に作成した日付)、 最終更新日、ラベルから選べます。このうちのいずれかを選択すると、フィルタの詳細を指定できるようになります。

「スケジュール」オプショ ンと同様に、ウインドウ右の「+(プラス)」ボタンをクリックして条件を追加し、「-(マイナス)」ボタンをクリックして条件を 除去します。フィルタの条件は、ポップアップメニューのオプションを変更するか、データフィールドに新しいデータを入力することで変更できます。

以下の例では、以下のいずれかの条件を満たすファイルのみがコピーされます:

  • Microsoft Office のファイルである(Word 書類など)。または
  • 「バックアップファイル」という名前のフォルダにある。または
  • 「プロダクトシート」という名前である。

 

 

オプションの概要

実行するのがバックアップ、起動ディスクバックアップ、あるいは同期のいずれであろうと、スクリプトのオプションは同じ方法で使用します(ここで選択できるものは、左の列にあるスクリプト一覧で選択しているスクリプトの種類により変わります)。

スクリプトの種類

スクリプトのオプションを利用する方法

バックアップ

「スクリプト」 > 「オプション」 > 「バックアップ・オプション」と選択します。

Command-4 キーを押します。

Personal Backup のメインウインドウ下部にある「バックアップ・オプション」ボタンをクリックします。

起動ディスクバックアップ

「スクリプト」 > 「オプション」 > 「起動ディスクバックアップ・オプション」と選択します。

Command-5 キーを押します。

Personal Backup のメインウインドウ下部にある「起動ディスクバックアップ・オプション」ボタンをクリックします。

同期

「スクリプト」 > 「オプション」 > 「同期オプション」と選択します。

Command-6 キーを押します。

Personal Backup のメインウインドウ下部にある「同期オプション」ボタンをクリックします。

これらのオプションを個別に説明します。

バックアップ・オプション

 

モード: このセクションでは、コピーするファイルの版をいくつ保持するかを定義します(版の数を決めるには、「バックアップの際に必要な決定事項」セ クションを参考にしてください)。デフォルトでは、Personal Backup はバックアップに指定したディスクがいっぱいになるまで、ファイルの古い版をすべて保存します。保存する容量が不足すると、古い版から自動的 に削除して容量を確保します。あるいは、古い版を特定の数だけ保存しておくことも可能です。

「モード」ポップアップメニューのオプションには、他に「各ファイルの最新版のみ保持」があります。これを選択すると、さらに 3 つのオプションが表示されます。

 

 

  • 「ソースから削除されているファイルは削除する」をチェックすると、ソースで削除されたファイルのコピーは、もうバックアップに含まれません。この場合、バックアップの内容はソースの現在の内容を正確に反映します。
  • 「ソースにある方が古くても、ソースのファイルでコピー先を上書きする」を チェックすると、バックアップが完全に一方向になります。ソースの中身がどんなものであれ、必ず保持しなければならないファイルがソースであることを前提 としています。これは例えば、バックアップのコピー 先にあるファイルは試験的に作成されたもので、ソースにあるファイルこそが「実際に」使用されるファイルであるといった場合に便利です。
  • 「ソースが 1 つだけ指定されている場合はコピー先のルートにバックアップする」を チェックすると、コピー先にソースの中身が直接コピーされます(つまりソースの内容とコピー先の内容が一致します)。ソースが複数あるバックアップでは、 コピー先にバックアップ用のフォルダが作成され、その中にソースの中身がコピーされますから、このオプションをチェックしておくことで、ソースが1つだけ の場合のソースとコピー先の関係が分かりやすくなります。

「アクセス権」セクションで、ユーザが読み込みの権限を持つファイ ル のみを Personal Backup がコピーするか、あるいは管理者権限を使用してすべてのファイルをコピーするかを決定します。後者を選択する場合は、スクリプトの実行直前に管理者のパス ワードを入力するか(「スクリプトを実行する前に認証を求める」)、前もって入力しておくか(「認証を求めない」)を選びます。

すべてのファイルをコピーするには、管理者レベルのアクセス権を持つユーザのユーザ名とパスワードを入力する必要があります。管理者権限を持つユー ザを確認 するには、アップルメニュー > 「システム環境設定…」 > 「アカウント」と選択します。管理者レベルのアクセス権を持つユーザには、名前の下に「管理者」と表示されます。

「詳細」オプションには、 「エイリアスを解決する」というチェックボックスが 1 つだけあります。このチェックボックスをオフのままにすると、エイリアスファイルはそのままコピー先に単純にコピーされます。チェックボックスをオンにす ると、各エイリアスのオリジナルのファイルが代わりにコピーされます。

注意:「エイリアスを解決する」をチェックしておくと、Personal Backup はエイリアスファイルの代わりに、そのオリジナルをコピーしようとしますが、オリジナルが保存されている場所によっては、見つからなかった り、アクセス権不足になったりして、エラーが記録されることがあります。エイリアスをお使いの場合は、できるだけ「エイリアスを解決する」を使わず、そのオリジナルファイルを含めたバックアップスクリプトを作成することをお勧めします。

起動ディスクバックアップ・オプション

起動ディスクバックアップには 4 つのオプションがあります。

 

 

  • 「管理者パスワードの入力を求めない」を チェックすると、スクリプトを定義する際に Personal Backup が管理者パスワードを入力するよう求めます。これでスクリプトの実行時にパスワードを入力する必要がなくなります。チェックしないと、スクリプトを実行す る前に毎回パスワードを入力する必要があります。
  • 「コピー先で何も削除しない」をチェックしないと、Personal Backup はバックアップの処理の過程でコピー先からすべてを消去し、ソ ースボリュームの完全なクローンを作成します。チェックすると、コピー先ボリュームにすでに存在する内容に加えて、 ソースの完全なクローンがコピー先ボリューム上に作成さ れます。このチェックボックスをオンにすると、起動ディスクバックアップの起動ディスクとしての機能に問題が起こる可能性があるので注意してください。単 にフォルダが削除されないようにしたい場合は、そのようなフォルダを例外条件に追加してください。
  • 「アクセス権を修復する」をチェックすると、システムファイルのアクセス権を検証します。Personal Backup は、エラーを検出した場合、その修正を試みます。
  • 「修復する」をチェックすると、起動ディスクバックアップを実行した後にコピー先ボリュームが正常な状態かを確認するために、このボリュームを検証します。Personal Backup は、ディレクトリエラーなどのエラーを検出した場合、その修正を試みます。

注意:起動ディスクバックアップを実行する場合、起動ボリュームと同一サイズのハー ドディスクにバックアップする必要はありません。例えば、250 GB のハードディスクが搭載されている Mac で、80GB しか使用されていないとします。この場合、起動ディスクバックアップはハードディスクのサイズが 120GB あれば作成でき、それでもまだ余裕があります。いずれにしろ、コピー先には空き容量が数 GB は必要です。ある程度の余裕がないと、 Mac に問題が起こった場合に、起動ディスクとしてバックアップが使用できない可能性があります(この数 GB の容量を Mac は仮想メモリファイルとして利用します)。

注意:起動ディスクバックアップ(クローン)を作成する過程で何か問題が起きると、できあがったクローンからMacを起動できないことがあります。は じめて起動ディスクバックアップを行った際には、必ずクローンで Mac を起動し、Finder や Dock、インターネットなどが正常に使用できるか一度は 確認しておいてください。通常、Finder および Dock の操作、そしてウェブブラウザとメールソフトの利用で支障がなければ、問題はないと考えられま す。

同期オプション

同 期は、2ヶ所にあるフォルダやボリュームに含まれるファイルを比較して互いに統合することで、その2ヶ所にあるすべてのファイルを同一の版にします。この とき、ソースとコピー先の両方のボリュ ームで同じファイルに変更が加えられている場合、どちらのファイルを最新として他方にコピーするかが問題となります。「同期」オプションの最初のポップ アップで、その動作を 指定することができます。

注意: 同期では、基本的にソースあるいはコピー先のどちらかでファイルが削除されると、他方でも削除が行われます。思わず必要なファイルが削除されてしまうなどの問題が起きる可能性がありますから、同期を使用する場合には注意が必要です。

注 意: 他社のデータバックアップソフトウェアでは、差分バックアップを「同期」と呼ぶことがありますが、Personal Backup では、基本的に「バックアップ」が可能な限り常に差分バックアップとなっています。差分バックアップが必要な場合は、「同期」ではなく「バックアップ」を 指定してください。

 

最初のオプション「確認」を選択すると、双方の場所で変更されたファイルが検出されると、その場でウインドウが表示されます。

 

左側にはソースにある書類の詳細が表示され、右側にはコピー先の同一書類の詳細が表示されます。ソースとコピー先それぞれのエリアの右下には、小さ な虫めが ねのアイコンが表示されます。虫めがねアイコンをクリックすると、クイックルックでファイルの内容が表示されます。Option キーを押しながら虫めがね のアイコンをクリックすれば、Finder でファイルを表示できます。

双方で変更があったファイルに対して、 2 つの選択肢があります。ソースに存在する版をコピー対象の「正式な」版にするか、あるいはより最近に変更されたほうをコピー対象にするかです。どちらをコ ピーするかを選択したら「続ける」 ボタンをクリックします。このとき、「その他の不一致を」チェックボックスをチェックして、次にポップアップメニューから希望する動作を1つ選択すること で、 同様の不一致をすべて無視することも可能です。不一致はまとめて後で解決したい場合は、「すべて後で解消」ボタンをクリックします。60 秒以内に何の選択 も行わないと、Personal Backup は「すべて後で解消」ボタンを押したものとして動作します。

「最後の同 期から双方の側に変更 がある場合」オプションでも、このような同期の不一致が起こった場合に Personal Backup が一貫してどのように動作するかを選択できます。「確認」以外に、「ソースからコピー」、「コピー先からコピー」、 「最新をコピー」、「最古をコピー」の 4 つのオプションがあります。

いずれのオプションを選択しても、Personal Backup は以前の版を削除し、ソースとコピー先のボリュームにファイルが1つだけ残るようにします。しかし、「コピー先で何も削除しない」チェックボックスをチェックすると、この動作を無効にすることも可能です。

「ア クセス権」セクションで、ユーザが読み込みの権限を持つファイルのみを Personal Backup がコピーするか、あるいは管理者権限を使用してすべてのファイルをコピーするかを決定します。後者を選択する場合は、スクリプトの実行直前に 管理者のパスワードを入力するか(「スクリプトを実行する前に認証を求める」)、前もって入力しておくか(「認証を求めない」)を選びます。

す べてのファイルをコピーするには、管理者レベルのアクセス権を持つユーザのユーザ名とパスワードを入力する必要があります。管理者権限を持つユーザを確認 するには、アップルメニュー > 「システム環境設定…」 > 「アカウント」と選択します。管理者レベルのアクセス権を持つユーザには、名前の下に「管理者」と表示されます。

仕上げ: ファイルの後処理

Personal Backup の「仕上げ」オプションを開くには、以下の操作のいずれかを行います:

  • 「スクリプト」 > 「オプション」 > 「仕上げ」と選択します。
  • Command キーと 7 キーを同時に押します。
  • Personal Backup メインウインドウの下部にある下図の「仕上げ」ボタンをクリックします。

 

 

「仕 上げ」オプショングループの先頭の「実行」チェックボックスは、「準備」 オプション同様に、スクリプトが終了するときに他のプログラムを実行するよう指定できます。実行するプログラムはどんなアプリケーションでもよく、 AppleScript、シェルスクリプト、Automator のワークフロー、あるいはスクリプトが完了したことを知らせるサウンドファイルなどが考え られます。チェックボックスをオンにすると、ダイアログボックスが 表示され、実行するプログラムが選択できます。後からプログラムを変更するには「選択…」ボタンをクリックしてください。

 

 

次の「コピー先を取り出す」オプションはデフォルトで有効になっています。これでスクリプトが完了したときに、Personal Backup がコピー先ボリュームのマウントを解除します。ポップアップメニューの2つのオプションから、Personal Backup でマウントされたボリューム(ネットワークボリューム等)のみを取り出すか、 または常に取り出すかのいずれかを選択します。

最後のオプ ションで、Personal Backup を終了するか、Mac をスリープ状態にす るか、あるいは他のスクリプトを実行するかを設定できます。「スクリプトを実行」を選択すると、追加のポップアップメニューが表示され、利用できるスクリ プトがすべて表示されます。Personal Backup に順次にスクリプトを実行させていき、最終的にシステム終了させることもできます。

「実行」をクリックしたときの動作

ここまでの説明で、すべてのオプションが設定されていることになります。コピーするファイルが選択され、Personal Backup がこれらのファイルをどうするか、例外はどう処理するか、スクリプトが完了する前後に何を行うかなど、すべて設定されました。それでは、実際に実行してみ ましょう。

スクリプトを実行するには、左の列からスクリプトをクリックし、次に右下にある右向きの三角形(「実行」ボタン、 DVD プレーヤーの再生ボタンに相当します)をクリックします。このボタンのラベルは、バックアップ、起動ディスクバックアップ、同期のいずれを行うかに よって異なります。

ほとんどの場合、 Personal Backup がスクリプトを実行中にユーザの邪魔をすることはありません。スクリプトの予約時間になったら、あるいは「実行」ボタンが押されたら、毎回ユーザが指示し た通りにプログラムが動作します。しかしながら、1つだけ明らかにそうでない場合があります。それは DVD などの取り外し可能なメディアにバックアップを 行う場合です。この場合は処理の経過を見て、必要に応じて新しいメディアを挿入する必要がある場合があります。

Personal Backup には、実行前、実行中、および実行後にバックアップや同期を検査する方法があります。「プレビュー」ボタンは、どのファイルがコピーされるか を正確 に表示します。「概要」ボタン、「チャート」ボタン、および「詳細」ボタンをクリックすると、処理が実行される様子を 3 通りの方法で見ることができます。「ログ」 は、正常に実行されたスクリプトと失敗したスクリプトの両方の記録を保持します。

バックアップは、消失したファイルを復元する方法がなければ役に立ちません。Personal Backup の復元機能で、どのファイルを元の場所に戻すかだけでなく、どの時点のファイルを復元するかも選択することができます。(復元について詳しくは「ファイルのバックアップおよび復元」の項を参照してください。)もちろん、ファイルは元のファイル形式のままで保存されているため、Mac OS X 上で単にフォルダからフォルダにドラッグすることも可能です。

プレビュー

これでバックアップスクリプトあるいは同期スクリプトが設定されました。しかし、具体的には何が起こるのでしょうか。正確にいくつのファイルがコ ピーされ るのでしょうか。どちらの方向にコピーされるのでしょうか。一時的に例外を作成したい場合はどうすればよいのでしょうか。Personal Backup のプレビュー機能にすべてお任せください。

スクリプト一覧からスクリプトをクリックし、Personal Backup メインウインドウの右下にある下図の「プレビュー」ボタンをクリックします。

 

 

あるいは、「スクリプト」 > 「プレビュー」を選択するか、Command キー、Option キー、そして Return キーを同時に押しても、プレビューモードに移行できます。

ウインドウの下部に以下のようなリストが表示されます:


 

 

左の列にはコピーするファイルやフォルダの名前が表示され、中央の列には予定されている処理、右の列にはコピー先での最終的なコピー場所が表示され ます。 不可視状態のファイルもこのリストには表示されます。ですので Finder では表示されない項目(上記の例では「.loc...」など)も表示されます。

さらに詳しい情報を見たい場合はどうすればいいでしょうか。 ウインドウの表示メニューをクリックすると、さらにリストの各項目に対する更新日と作成日の情報が表示されます。表示している情報にはチェックマー クがその横に表示されます。任意の情報を隠すには、表示メニューからもう一度項目を選択します。

 

以下は、すべての情報を表示した状態の上図と同じウインドウの例です。

 

選択しているオプションによっては、Mac の画面にすべて表示しきれない場合があります。列の幅は変更できるので、最も重要なものだけ見やすいように調節す ることができます。幅を調節するには、 カーソルを列ヘッダの右側の線上に置いて「両方向矢印」カーソルを表示させ、希望する幅に広げたり縮めます。下図は「ソース」列の幅を広げる前の様子で す:

 

 

列の幅を広げて、各ファイルのパスが完全に見えるようになった状態が下図です。

 

 

ファイルパス上をダブルクリックすると、該当するファイルを Finder 上で表示します。

コピーしたくない項目を見つけた場合はどうすればいいでしょうか。もちろん 「例外条件」でルールを作成することもできますが(「Personal Backup のスクリプトオプション」「例外条件」の 説明を参照)、 Personal Backup にはさらに素早く個別の例外を設定する方法があります。「処理を変更」列で対象項目に対するアクションをクリックします。ポップアップメ ニューが表示されますので、下図のようにこの項目のコピーを無効にすることができます。

 

 

バックアップスクリプトや同期スクリプトが希望通りであることを確認したら、 「実行」ボタンを押せば即座に実行できます。また、ウインドウの右下にある下図の「編集モード」ボタンをクリックすれば、メインウインドウに戻ることもできます。

 

他にご質問がございましたら、リクエストを送信してください

コメント